Release Notes AC Toolbox 4.5.7
Comments: paulberg@actoolbox.net
NEW FEATURES
1. The primary new feature is that use with macOS Sierra is now supported.
2. The current version is released as Intel-only. Older versions that are universal binaries are still
available on the website.
3. Minor adjustments were made to help texts and to the generator ADD-TO.

Release notes AC Toolbox 4.5.6
NEW FEATURES
1. Some additions and changes were made regarding the use of spectra.
a. The tool LIMIT-SPECTRUM was added. It can limit a spectrum read with READSPECTRUM-FILE to only include pitches within a given range. The result is a spectrum which can
be used with various spectral tools and generators such as spectrum->pitch, spectrum->chord,
etc.
b. The SORT keyword for a number of spectral tools and generators was adjusted to allow
sorting pitches in either ascending or descending order. This effects SPECTRUM->PITCH,
SPECTRUM->FREQ, SPECTRUM->CHORD, and SPECTRUM->WINDOW.
c. Keyword NAME was added to SPECTRUM->RANGE. This allows the range to be returned
as note names rather than note numbers.
d. SPECTRUM->WINDOW was adjusted to also print peak numbers. This information could
be useful when specifying chords with SPECTRUM->CHORD. Keyword RAW was also added. It
limits the printed information to frequency and amplitude and does not print the Midi equivalents.
2. Popup-menus are available when the cursor is in a text edit box.
a. When the cursor is CTRL-clicked (or the right mouse button is pressed), a popup menu
appears. If the text edit box is in a dialog for defining an object, e.g. in a data section dialog, the
selected input can be used to plot values, print values (in the style of For Example), and make a
histogram. This can be seen as a shortcut for using the Plot Other, Histogram Other, and For
Example dialogs. Each time a menu item is selected, the selected input is evaluated again which
could result in a different series of values. Possible options are defined in the dialogs for Plot Other,
Histogram Other, and For Example.
b. The popup menu also includes some editing commands (cut, copy, paste, etc.).
c. Help for the selected text can be found by choosing the appropriate item from the popup
menu.
d. The editing commands and help item may also be available with other dialogs.
e. The operating system may add other menu items relating to Services selected in
Keyboard System Preferences. These additional items are not related to the AC Toolbox.
3. A POPUP MENU was added for the 'Do It' button in the FOR EXAMPLE dialog. When the button is
CTRL-clicked (or the right mouse button is pressed), a popup menu appears. The same values that
were printed in an example window can be plotted or used to make a histogram. Some plotting
options are available when the 'Options' button is selected.
4. The POPUP MENUs for the right buttons in the PLOT OTHER and HISTOGRAM OTHER dialogs
were adjusted to use the same values that were plotted or used for a histogram when performing
the actions selected from the popup menu. This is a departure from the behavior in 4.5.5 when
just the input was used to make a histogram, etc. but not the actual calculated values.
5. POPUP MENUs are available for the titles RHYTHM, PITCH, and VELOCITY in a data section
dialog and NOTES in a note section dialog. When one of those titles (on the left side of the dialog,
not in the text box) are CTRL-clicked (or clicked with the right mouse button), the rhythm, pitch,
or velocity values of the object are plotted or used for a histogram. This can be seen as a shortcut
for the Plot Section dialog or the Histogram Section dialog. The options selected in those dialogs
effect what happens with the popup menus. This behavior is different than what is described in
number 2 above which just uses the input to make new values to plot, etc.
6. Generator JITTER was added. It provides a symmetrical, uniform random distribution around a
given value. The range of deviation can change over time. In some cases, this generator may be
more convenient to use than the SHAKE generator.
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7. An optional multiplication factor was added to FROM-NUMBER. This makes it easier to do
something for half the number of events and something else for the other half.
8. An option was added to print channel numbers as instrument numbers when printing a TEXT
SCORE.
ADJUSTMENTS
9. The shape of an exponential decay produced by LINE and LINE-SEGMENT was adjusted to have
the same behavior as that produced by GENERATE-LINE and EXPONENTIAL-MOTION.
10. If an orchestra is chosen for CSOUND FILE OPTIONS using the 'Use Open Orc File' menu item,
the file name is added to the list of recent orchestra files available in the popup menu via the
'Select' button.
11. If the AC Toolbox is opened by double-clicking an environment or example file, the file name is
added to the list of recent environments or examples.
12. The number of values to be produced when making a histogram (Tool>Histogram>Other) is
now stored in the preferences and set when the AC Toolbox is loaded.
13. A general information text was added about popup menus. It can be found in the Index dialog.
14. The behavior of the menu item Help>Lookup Selection was slightly expanded. If an entire
expression has been chosen, the first item is used when searching for help.

Release notes AC Toolbox 4.5.5
SUBHARMONICITY
1. Grisey referred to a concept known as subharmonicity: the harmonic series descends instead of
ascends. Keyword SUBHARMONIC was added to the generator HARMONIC-CHORD to allow this
behavior.
2. This idea was expanded to apply to other spectral data. SPECTRUM->MIRROR can mirror the
spectral data read with the tool read-spectrum-file.
3. SPECTRUM->RANGE was added. It returns the lowest and highest note numbers used in data
from read-spectrum-file. This information could be useful when modifying spectra with spectrum>mirror.
CSOUND
4. Several additions were made to the Csound File Options dialog.
a. If the 'Select' button for an orchestra is Ctrl-clicked, a popup menu with recently selected
orchestra files appears.
b. If an orchestra file is open in the editor, e.g. after having been double-clicked in the
Finder, the menu item 'Other>Use Open Orc File' will insert that file name into the orchestra slot in
Csound File Options.
c. Csound directories should not contain spaces or diacritical marks. If a directory is selected
with these characters, an error message is returned.
d. A standard Csound installation will install both the 32 and 64-bit versions of Csound. A
button panel labelled 'Internal Resolution' allows choosing between these resolutions. For realtime
output, 32-bit resolution may be more convenient.
e. Recent Csound distributions contain the Csound manual in html format in versions with
and without the use of frames. If a frames version is available, it can be selected with a check box
and opened with the 'Manual' button.
f. If different versions of Csound have been installed, it may be necessary to point the
Toolbox to the desired version of the Csound manual. The selection can be made with the button
'Select Manual'.
g. If Csound has been installed, the menu item 'Other>Sound File Info' is available. It can
return information about a selected sound file. This can be any sound file, not necessarily one
made by Csound.
5. A couple of bugs concerning Csound score objects were fixed:
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a. One involved using FROM-NUMBER when there are multiple layers containing UNTIL-TIME.
This also applied to OSC scores as well.
b. Another concerned generators writing ratio values to the score file.
GENERATORS AND TOOLS
6. The generator EXPCURVE-VALUE was added. It is yet another way of doing random exponential
distributions. A specific curve can be specified as an exponent. This curve could decrease or
increase. Values will always be between a specified limits. XCV is the shortcut for this generator.
EXPCURVE-CHOICE uses the same algorithm to pick values from a stockpile.
7. Generator GENERATE-AVERAGE averages a number of applications of a generator. This is a
quick and easy way to realize various statistical distributions such as a triangle distribution and a
Gaussian distribution.
8. The keyword CHECK was added to RANDOM-VALUE. If bound to t, the same value will not occur
twice in a row.
9. The keyword SCALE was added to 1/F-VALUE and NOISE-VALUE. Both generators tend not to
reach their lower or upper limits. SCALE can be bound to a multiplication factor to increase the
range of the output which nonetheless is constrained to the original limits.
10. LINE and LINE-SEGMENT were adjusted to produce integers or floats in a way similar to other
generators. Previously, these generators always produced floats. Now, if either the start or end
parameter is a float, the result will be a float. Otherwise, the result will be an integer.
11. The behavior regarding floats and ints was also adjusted for GENERATE-LINE.
12. It is no longer necessary to use the keyword EXPONENTIAL if the CURVE keyword is used with
generators LINE, LINE-SEGMENT, GENERATE-LINE, GL, and MORPH.
13. ACT-IF was expanded to allow the use of combinations of conditions when making decisions.
This can be done with CONSTRAINT-AND, CONSTRAINT-OR, or CONSTRAINT-NOT. The tool
ANYTHING can also be used as part of an expression in ACT-IF.
14. Parameters for SERIES-VALUE, LORENZ, BPM, and MM can now vary over time.
15. Stockpiles can be used as input for UNTIL-TIME and SELECT-PATTERNS.
16. Keyword ROUND was added to generator RAMP.
INTERFACE ADJUSTMENTS
17. The algorithm for balancing parentheses is improved. Menu item 'Edit>Balance ()' is now more
useful for finding the matching parenthesis in text input boxes.
18. Several generators can be plotted in the same window using the the dialog produced by
'Tools>Plot>Other'. If several generators, stockpiles, lists, etc. are entered in the dialog, the
results will be plotted in the same window with different colors.
19. In the Plot Other dialog, Ctrl-clicking on the 'Plot' button produces a menu item 'Histogram'.
This will produce a histogram using the same input data as the Plot dialog. It does not use the
same values that were plotted; only the same input is used. This is a convenience to get different
views of possible outputs of the same input.
20. In the dialog produced by 'Tools>Histogram>Other', Ctrl-clicking on the 'Histogram' button
produces a menu item 'Plot'. This will plot values using the same input. It does not use the same
output values, only the same input.
21. The popup menu item 'Play' was added to the buttons in the dialogs for parallel streams and
multi-controller streams. The menu appears when the button is Ctrl-clicked.
22. The popup menu item 'Histogram' was added to the buttons in dialogs for making stockpiles.
This produces a histogram of the actual data in the stockpile.
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23. The dialog produced by menu item 'Tools>Play Selection/Loop' can play and plot Midi objects
in addition to notes.
DOCUMENTATION
24. Examples in help windows can be evaluated using the ENTER key. It is also possible to use the
key combination CMD-RETURN to do this. This last combination is familiar for people who work
with the new SuperCollider IDE.
25. The tool PLOT-MANY was added and is occasionally used in help windows to plot several
functions in one window.
26. The menu item 'Help>What's New' has been added. It opens a window with the release notes
for the current version of the AC Toolbox.
27. The file with the SuperCollider SynthDefs which are used with the OSC dialog examples is now
available in two formats: as a rtf file (for the older versions of SuperCollider) and a scd file for
newer versions. The files are in Support/FileExamples.
28. Various adjustments were made to the tool HELP->FILE which gathers online help into an html
or text file.
29. A general help item was added to explain the differences between the various random
generators with an exponential distribution. The item is available via either index and is called
'Exponential Generators'.
MISCELLANEOUS
30. A bug involving interpolation with the LOOKUP generator was fixed.
31. The problem wit plotting a list containing both single numbers and list was solved.
32. The format for saving Csound and OSC score objects as examples was changed. After the file
has been loaded, the objects can be remade without having to be specified or applied.
33. The format for saving Midi streams to the environment file was changed. This solved
occasional issues when an environment with streams was loaded.
34. The keyboard shortcut for the menu item 'Edit>Insert Newline' was changed since the
previous shortcut is now used to evaluate examples in the help windows.

Release notes AC Toolbox 4.5.4
New Features
1. Several extensions were made to the generator generate-line.
a. It is now possible to deviate from the generated line by binding a function to the keyword
ADD. This could, for example, allow for random deviation around the generated line. Keywords
MIN and MAX can be used to limit the range. Together these features allow for an approach similar
to the line with deviation within a fixed range described by Tenney in his article Computer Music
Experiences, 1961-1964.
b. Keyword DISJUNCT causes both the start and end values to be calculated for each line
segment. Instead of the line going from a->b->c->d, it goes from a->b, c->d …
c. Values in a stockpile (or produced by a generator) can be interpolated by binding the
START parameter to nil. The line will then go from the first value in the stockpile, to the second,
then the third, etc.
2. Keywords MIN and MAX were also added to the generator spray. It can now also be used for a
Tenney-like deviation from a changing mean value. Spray derives the change from a shape.
3. fm-chord. This generator allows chords to be produced as a simulation of the process of
frequency modulation. It is related to the work of some spectral composers.
4. join->chord. This generator can join the output of various generators into a chord. E.g. makechord could be used to produce chords in different regions and then these could be joined into one
chord. Generators such as harmonic-chord or fm-chord could produce chords with different
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qualities which could then be joined on the fly with this generator.
5. cleanup-chord. This generator filters repetitions and other specified intervals from chords
produced by generators or read from lists. It is primarily useful for chords produced by generators
such as join->chord, fm-chord, harmonic-chord, etc. make-chord already contains options for
filtering data when a chord is made.
6. Generators line, line-segment, and morph can now produce exponential curves in addition to
linear interpolations.
7. Two extensions were made to the tool extract. Extract is used to return a list of parameter
values such as pitch from a section.
a. Keyword CHORDS will gather events in a section with the same start time into one event
before extracting pitch, etc. Each chord will have one duration, velocity, and channel value but
could have multiple pitch values. This could be useful when manipulating data read from a Midi
file.
b. In the standard use of extract, rests would produce negative values for rests and zeroes
for pitch and velocity. Keyword RESTS can be used to disallow the placeholders for rests. This
provides cleaner data for use in generators.
8. Two functions were added to work with derive-transition-table. When chord-pitch is used as the
key, it will gather simultaneous pitches into a list before the transition table is generated. chordnote will gather the simultaneous pitches into a list as part of a note specification before the table
is derived.
9. The functionality of convert and convert2 was expanded to allow converting chords. Chords can
be produced by generators such as fm-chord. These chords can be expanded or contracted to fit a
different range.
10. Three tools were added to perform logical operations on filter expressions used with the
generators with and without, and with the tool filter-stockpile.
a. constraint-and is true if the result of applying all of the filters is true. For example, two
filters could be combined so that a note number from a generator will be rejected only if it is < 70
and a member of pitch class 0.
b. constraint-or is true if one or more of the filters passes a value. For example, a note
number is passed if it is < 60 or belongs to pitch class 0.
c. constraint-not negates the value of the constraint to which it is applied. For example, a
note number is passed if it is not from pitch classes 0,4,7.
11. Tool gather-until was expanded with keyword ALWAYS-LESS. Instead of gathering values
whose sum is >= some value, it will always (if possible) return values with a sum <= some value.
This tool is primarily of interest when grouping rhythmic values.
12. rearrange-stockpile was adjusted to allow type ORDER to return a stockpile longer than the
original if the order is a list or stockpile with more values than the original. Also, rs was added as a
shortcut for rearrange-stockpile.
13. read-text-file was adjusted to allow a file name as an optional argument.
14. with-probability. This transformer can limit a transformation to a certain percentage of the
events: e.g., only 30 % of pitches will be transposed.
15. Transformer remove-doubles was adjusted to optionally allow only one pitch per pitch class in a
chord.
16. In the Csound File Options dialog, the Select buttons for the directories (Sound, Analysis,
Sample) will show the corresponding directory in the Finder when they are CMD-clicked.
17. In the Objects dialog, the function of the remake button has been expanded. If a Csound score
object or an OSC score object is selected when remake is clicked, the object will be applied to
produce a new (audio) output.
18. change-object-order. This tool can be used to drag objects to the desired chronological order.
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It is primarily useful if objects are being saved as examples and their order is important.
19. A button was added to the Play Selection/Loop dialog to plot the selected part of the section.
Bug fixes and other adjustments
20. SuperCollider 3.5 changed the location of the SuperCollider server application. This application
is needed to render OSC score objects. The AC Toolbox was adjusted to look in either the new or
the old location for the server. If there is a problem rendering an OSC score object because the
server is not found, select the Find SuperCollider button in the OSC File Options dialog.
21. When AC Toolbox objects (instead of numbers or symbols) were stored inside a stockpile, this
led to problems when reading in the environment file containing the stockpile. This issue was dealt
with by removing binary objects from a stockpile (if they are stored there) when the environment
file is written. When the file is read in, the stockpile will be remade when it is needed.
22. Some issues related to using the medium font size were resolved.
23. A bug concerning the window list not being properly updated when an object was renamed has
been resolved.
24. The problem caused by N not being an integer in the generators line and line-segment has
been fixed.
25. The representation of note numbers when editing a section containing chords with several
notes >= 100 has been cleaned up.
26. The application was compiled with a new version of the LispWorks compiler. This may
unexpectedly solve some problems and equally unexpectedly cause some new ones.

Release notes AC Toolbox 4.5.3
New features
1. select-stockpiles. This generator allows a new stockpile to be selected in a generator while it is
reading from a stockpile.
2. Three conditional transformers for sections were added.
a. transform-if. If one parameter satisfies a certain condition, the same or another
parameter will be transformed. For example, pitches > 84 could be given longer durations. Or all
notes with start times within a certain range will get their pitches transposed.
b. transform-and. Several conditions can be expressed. If all conditions are met, a
parameter will be transformed. For example, if pitch > g5 and velocity is equal to p, the duration is
doubled.
c. transform-or. If one or more of the conditions are met, a parameter is transformed. If
pitch is low or the duration is long, the channel is changed.
3. Other new transformers:
a. transform-by-index. Values at the specified index positions are transformed.
b. tran. A transformation can be expressed as a sequence of simple arithmetic expressions
involving constants, lists, stockpiles, or generators. E.g. (tran + 12 + (random-choice
'(-0.5,0,0.5)))
c. insert-rest. Rests can be entered into a section if a note starts at the indicated start
times. The remaining events will start later.
4. insert-to-section. A section can be interrupted by inserting other sections at various time points.
5. exprand-value, exprand-choice. These generators reflect a quick and easy approach to getting
an exponential value that is always within an appropriate range. It uses a technique that is less
mathematically conventional that exponential-value does.
6. A keyword or optional parameter round was added to many generators, tools, and transformers.
This forces the output to be quantized to the specified unit. For example, (random-value 1.0
3 :round 0.25) would only choose values which are multiplies of 0.25. When used for pitch, a
generator could round values to be quarter-tones, etc.
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7. roundq. This tool rounds constants or lists to some quantization unit. It can also be used to
round values in on-the-fly or tran.
8. convert2. This tool is similar to convert except the optional parameters are expressed as
keywords. This makes it easier to selectively use only one of the additional parameters, such as
round. convert/time2 also uses key words and allows values to be quantized.
9. make-lookup-table. This tool can now use generators, lists, or stockpiles as values that are
associated with keys. The result is used with the generator lookup.
10. read-from. This generator was adjusted to allow the number parameter to change over time
when a shape or mask is used to read values.
11. gaussian-value. The default behavior of this generator was changed to return floating-point
values instead of integers. The keyword round can be used to quantize the output.
12. series-value. Values no longer have to be integers. The keyword step was added. This allows a
set of values to have the distance expressed by that parameter. For example, (series-value 1.0
10 :step 0.5) would choose, without repetitions, from the values 1, 1.5, 2, 2.5 … 10.
13. at-csound-time. This tool transforms an event parameter which occurs between the specified
times in a Csound score file. For example, P5 could have 2000 added to its values that occur
between time 10 and 15 seconds.
14. at-osc-time. This tool transforms an argument of an event that starts between the specified
times in an OSC file. For example, the freq argument could be transposed if it occurs between time
5 and 6 seconds in the file.
15. Additions were made to the window for Csound File Options to block the printing of messages
from Csound and to open the most recent csd file made in the current session.
16. A menu item, Render CSD, and a keyboard shortcut were added to render the most recent csd
file. This is particularly convenient if Csound files are rendered in real time.
17. A render button was added to the window for OSC File Options. It will render an OSC file made
by the AC Toolbox. This allows rendering a file with different output options.
18. A simple mechanism for balancing parentheses in text input boxes was added. The menu item
Balance () or its keyboard shortcut will jump to the corresponding parenthesis if the cursor is
before a left parenthesis or after a right one.
19. An option was added to the window for making a text score. Instead of printing note names, it
also possible to print note numbers.
20. In the Preferences, the transparency slider will change the transparency of the Preferences
window. The transparency of other existing windows is not affected. Subsequent windows will use
the new value.
21. The Preferences window also contains an additional possibility for font and dialog size:
Medium. This is between Normal and Big.
22. Various changes were made to the Text Output window and the messages printed there.
23. quantize. This transformer can now have an optional parameter bound to another transformer
that should be applied before the quantization.
Documentation
24. A chapter about transforming objects was added to the Tutorial.
25. Some addition general info items were added to the help in the application concerning:
a. transforming with time limits
b. relating parameters
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c. dealing with parentheses
26. show-help. This tool is now used in the edit pane of some help windows. It makes it
convenient for the user to move to the help for another related generator, tool, or transformer.
Bug fixes and other adjustments
27. Various issues surrounding the use of stream sliders and slider-value were addressed.
28. triangle-value and linear-value were changed to produce floats or integers more appropriately.
29. Changes where made to replace-by-index and shove to deal with erroneous input in a more
robust fashion.
30. sieve-filter now also works with the whatever parameter in the filter method.
31. When a generator is used in a cal expression, it is applied again for each number being
calculated.
32. An occasional problem with lookup when a key was an integer and the value a float has been
resolved.
33. A solution was found for the problem of blocking floats in convert.
34. The special Csound command options for realtime rendering were removed. This seems to
improve realtime rendering.
Shortcuts
35. Shortcuts were added for exprand-value (xrv), linear-value (lv), triangle-value (trv), makechord (mc), read-from (rf), and series-value (srv).
MacOS 10.7
36. There are no known compatibility issues between the AC Toolbox and MacOS 10.7 (Lion).
Users that make Csound or OSC files may want to expressly choose an application to open audio
files (in the Csound File Options or the OSC File Options) rather than rely on the system default.

Release notes AC Toolbox 4.5.2
This release is primarily a maintenance update fixing some bugs and adding a few new features.
New features
1. The tool act-sort was added. Stockpiles and lists can be sorted in various ways. Rhythms can be
sorted in ascending or descending order. Low pitches can be moved to the beginning. Low or high
pitches can be moved to the front. Values within a certain bandwidth can be moved to the front,
etc.
2. Streams can now read values from a group of sliders. The sliders are available via the
menu item Tools>Stream Sliders. The interface can be configured to contain 8-64 sliders.
3. Generator slider-value is used to read from the stream sliders. It maps the slider position to a
value in the range specified in slider-value. The mapped values can also be printed.
4. If Capybara/Pacarana is specified as the Midi output device, an interface containing one or more
Kyma Sliders is available via Other>Kyma Sliders. These sliders can be mapped to send data to
controllers in Kyma with the names !cc01, !cc02, etc. This is intended as a convenience so that
amplitude and other values in Kyma can be controlled from within the AC Toolbox.
5. Tool layer-number is available for use with Csound and OSC score objects. When more than one
layer is specified, layer-number will return the current layer number during the calculation. This
allows different layers in a Csound or OSC score object to use different values, boundaries,
generators, etc.
6. The spray generator can now specify generators to determine the deviation. Previously, only
uniform random deviation was possible.
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7. Additional shortcuts:
sf for sf-name
gsf for generate-sf-name
sl for slider-value
Bug fixes
8. The accuracy of calculating start times for data sections, controller data objects, and program
data objects was improved.
9. The functioning of the Remake button in the Objects dialog was adjusted.
10. The problem with keywords in the Extra edit boxes in the Csound and OSC score dialogs was
fixed.
11. The problem which occurred if the counter in take was a real number was resolved.

Release notes AC Toolbox 4.5.1
Editing objects
1. The output of some objects can be now be edited by hand. With sections, a spreadsheet-like
text presentation of the pitch, rhythm, and other values can be used to change specific numbers.
Midi objects can be edited in a similar way. Stockpiles can have values modified or added. Shapes
and masks, when specified or generated, can be edited by drawing.
Select the object in the Objects dialog and then choose Edit.
Tutorial
2. Three chapters were added to the Tutorial.
a. Tutorial 22 deals with converting section data to a form of musical notation. This is done
by using FOMUS to prepare data for LilyPond or MusicXML (which can be read by Finale, Sibelius,
and other programs).
b. Tutorial 23 concerns additional ways of filtering values as they are being generated as
well as some ways to filter sections. The latter can allow conditions involving more than one
parameter.
c. Tutorial 24 discusses some tools and generators pertinent to pitch and intervals.
3. A version of the tutorial in epub format is now available for download from the web site. It is
suitable for use with mobile devices such as iPhones, iPads, Android-based phones, and any other
platform capable of reading this standard format.
4. A section was added to Tutorial 6 about editing objects.
5. An example was added to Tutorial 21 to demonstrate using b_gen commands in an OSC score
object. Related dialog examples bunch2 and osc5 were added to Dialog Examples.
New Generators, Tools, and Transformers
6. Several functions for filtering sections:
a. filter-if allows filters to be applied to some events while others are passed unfiltered. For
example, if the channel is 1, apply a band-pass filter to pitch.
b. filter-and applies several different constraints and only passes an event if all constraints
are met. For example, an event may be passed if a pitch was within a certain range and rhythm
was below a certain value.
c. filter-or allows an event if one of several constraints is met. For example, events which
are high, short, or loud are allowed.
d. select-channel and reject-channel accept or reject all events in the specified channels.
e. value-pass and value-reject pass or reject values equal to one specific number. These
filters are useful in combination with filter-and, filter-or, and filter-if.
7. Probability-filter is a similar to a bank of band-pass filters except only a certain percentage of
the values are passed. For example, you could keep all low values and only some high values.
8. Anything is a tool for specifying additional constraints for the generators with and without.
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Expressions such as anything < c4, or inside the range c4 to c5, or outside the range 100 to 200
can be expressed.
9. Pitch-class is a constraint for the generators with and without. Values are reduced to pitch
classes before determining if they should be accepted or rejected.
10. Allow-interval is a generator that passes a value produced by another generator if the interval
from the previous value is one of the allowed intervals. This is a way to restrict the interval
content. The generators with and without limit specific values. Allow-interval limits specific
intervals.
11. Some new transformers:
a. if-channel will only apply another transformer if the event is in a specified channel or list
of channels. For example, only pitches in channel 1 will be transposed.
b. transform-some can limit the application of a transformer to values within one or more
specified ranges. For example, low values can be transposed down an octave and high values up a
minor third. Values in the middle range will not be affected.
c. force-mod performs a modulo operation on the result of a transformation. This may be
useful when dealing with pitch values or intervals.
d. a method was added to the join operator to connect two or more transformers. The
output of one transformation will be used as the input to the next. For example, tempo could be
stretched and have a random deviation added.
12. Related to sets of pitches or intervals:
a. mix-chords returns a mixture of two chords. Some values from each chord will be
included. This can be seen as a form of interpolation between chords.
b. pitch-matrix produces a matrix of transpositions of a row.
c. invert-stockpile inverts a row or matrix.
d. retrograde-stockpile reverses a row or matrix.
e. make-row produces a list of values that could be treated as a (12-tone) row. The first
value is 0. The other values are randomly chosen. The length of the row can be specified.
13. Two tools that may be useful when writing sound files directly from the AC Toolbox:
a. seconds->samples calculates the number of samples needed to fill a given length of time.
b. freq->samples returns the number of samples in a period related to a specified frequency.
Interface
14. A popup menu for playing, plotting, editing, and do various other things with an object
appears by clicking on the Make button with the right mouse button (or by using CTRL-Click). This
works with several dialogs, such as the ones for defining sections and stockpiles.
15. When making sequential and parallel sections, etc., objects names can be dragged from the
Objects dialog.
16. The names of generators, tools, and transformers can be dragged from the Index and
Annotated Index dialogs. The name of the generator and its arguments will be entered. The
arguments should be replaced with the actual values.
17. Additions were made to the Objects dialog. Objects names can be filtered. An Edit button was
added. It can be used to edit values inside objects once the objects have been made. The Info
button was made more easily available and can provide information about sections, midi objects,
communities, and stockpiles.
18. A filter was added to the Dialog Examples dialog to filter example names.
19. When drawing masks, the line selected by the radio button (Top or Bottom) will be thicker.
20. Forward and back arrows at the bottom of help windows can be used to navigate to previously
accessed help windows.
21. General information which was only present via items in the Index dialog, is now also available
in the Annotated Index.
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22. Menu item Select () can be used to select all text within matching parentheses. This can also
be used to check if parentheses are balanced in an expression.
23. Several changes were made in regard to plotting Midi objects and Midi sections. Plotting was
also optimalized to allow for plotting Midi objects with a large number of values.
24. File names can be automatically generated when writing FOMUS files.
Miscellaneous changes
25. General information about Writing Sound Files and Editing Objects was added to the Index and
the Annotated Index.
26. Select-patterns can now have an optional argument to determine the order of elements
returned from a chosen pattern.
27. Pitch-and-octave can have chords as input.
28. The accuracy of calculating start times for data sections was improved.
29. Adjustments were made to the functionality of interpolate-chords, duplicates, replace-if, clip,
logist, logist2, invert, beta-value, beta-choice, and series-choice.
30. If a stockpile has been specified but not made, it will now automatically be made if mentioned
in another expression. This is particularly relevant if example files have been accessed.
31. Code object was added as a new class of objects. Lisp code can be stored in this object and
saved with the other objects in an environment.
32. Bugs were fixed in regard to writing FOMUS files from density sections, OSC files from
sections, and the tool more-than.
33. The application was compiled with a new version of LispWorks. This may solve some problems
and cause some new ones.
34. Additional shortcuts:
a. ut for until-time
b. sc for series-choice
c. pick for series-value (sv is already in use for sieve)
d. fst for from-start-times
e. mv for masks&values
f. spread for pitch-and-octave

Release notes AC Toolbox 4.5
Tools to facilitate music notation
1. The primary new feature in this version is the ability to write section data in a form that is
suitable for use by FOMUS, a program for formatting data for music notation. FOMUS produces
data which can be read by LilyPond. It can also produce data in MusicXML format which can be
read by Finale, Sibelius, and some other programs.
2. In the dialog created with the menu item 'File>Write FOMUS File', various options can be
specified to include in the FOMUS file to assist in the formatting process. These options including
the writing of quartertones, constraining beat divisions and tuplet durations, etc. Various
convenience options can also be specified.
3. One of the options when writing a FOMUS file is to use Luc Döbereiner's Pre-FOMUS Rhythm
Quantizer which is included in this release. In some cases, this provides a more plausible
interpretation of the rhythm data in a section.
4. Additional information about using FOMUS in the AC Toolbox can be found in the Index or under
the help button in the 'Write FOMUS File' dialog.
5. The AC Toolbox does not contain FOMUS. This program must be downloaded and installed
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separately. There may not be a PPC version of FOMUS readily available.
New tools and generators
6. Limit returns part of a list or stockpile that is between or outside certain specified limits. This
could be useful when using -choice generators. It can also return values <= or >= to certain
thresholds.
7. No-more-than returns a list of values with no more than a certain number of some specific
values. E.g. a list may contain 50 values but no more than 3 of them may be 60.
8. More-than is a tool which can be used with the generator without. It limits the number of times
that certain values will be allowed. This is similar behavior to no-more-than except that without is
a generator and produces a continuous stream of values.
9. With is a generator which is a quick and easy way to determine which values produced by a
generator or stockpile should be included. Results can be limited to specified values or to values
which meet a defined condition (such as < 1.0). This is the opposite of the generator without.
10. Sample is a generator that samples values from a generator or a stockpile. For a generator,
this means that the generator is applied several times before a result is returned.
11. Clip-generator clips values from a generator to be within certain limits.
12. Allow-larger-quantization-stack may expand the functionality of the Pre-Fomus Rhythm
Quantizer when dealing with large sets of data.
Modifications to tools and generators
13. Keyword :limit was added to make-chord. This limits the range of the chord to ±limit number
of steps from the first value chosen for the chord.
14. In generator sine, the value for n can change over time.
15. From was adjusted to deal more accurately with a floating-point value as step size.
16. A method was added to extract to allow channel data to be extracted from a section.
17. Generate-diversity can be stopped after some specified number of unsuccessful attempts of
finding a value.
Additional menu items for convenience
18. The Help menu contains items to navigate forward and backwards among help windows.
19. Tools>Plot>Selected Object will plot (if possible) the object selected in the Objects dialog. This
means that an object which has just been made can be plotted with a keyboard shortcut instead of
using the button in the Objects dialog.
20. Tools>Selected Object as Text will print a text representation (if possible) of an object selected
in the Objects dialog.
21. A keyboard shortcut was added to the existing menu item Tools>Test Value.
22. Window>Cleanup Windows and Objects will close most windows and delete all objects.
23. Window>Example Window to Front will bring the most recent examples window to the front of
the open windows.
24. Help>Section Info will create an info window for a section, Midi performance object, or
community when one of those objects is selected in the Objects dialog. Otherwise, it will bring the
info window to the front if it is already open.
Shortcuts
25. Several shortcuts (for tools and generators) were defined:
density - for density-of-start-times
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ms - for make&sort
sbl - for scale-by-layers
fn - for from-number
ro - for round-off
cg - for clip-generator
Other
26. Improvements and changes were made to various plotting routines. In particular, plotting data
read with read-tracks-files is more accurate. The behavior of plotting with lines (instead of with
points) was adjusted in some cases. The use of minimum and maximum values when plotting was
in some cases altered when the values exceeded those boundaries. Some histograms can now also
be presented within specified minimum and maximum values.
27. Fixed a bug regarding chaotic-notes, stockpiles, and saving the environment.

Release notes AC Toolbox 4.4.4
New tools and generators
1. Inside-OSC can be used when creating an OSC score. It allows a synthdef to be updated during
a current OSC event, for example frequency could be changed during a sound. The methods for
rendering, plotting, transforming, and making a histogram of an OSC score were adjusted to
accommodate this possibility.
2. Attacks makes a list of attack times suitable for density sections, Csound scores, and OSC
scores. It uses a method similar to what Xenakis did in his Stochastic Music Program. Intervals
between attack points can be produced with various generators. The resulting list is scaled to be
between a begin and end time.
3. Shuffle is a generator that returns a series of values from a reordered stockpile. The stockpile
can be treated as one group or several small groups. Values are shuffled within the limits of the
group.
4. Make-many-variants creates several variants of an object. Each new variant is given a name
from a user-supplied list of names. Each variant is entered in the environment using the new
name.
5. Generate-sum adds several values from a generator, etc. to produce the next value in a series.
For example, the result could be the sum of several random numbers.
Additions or adjustments to existing tools and generators
6. The keyword :interpolate was added to the generator lookup. Numbers not found in the lookup
table will return a value interpolated between the two nearest values.
7. Keyword :curve was added to generate-line and exponential-motion. It controls the sharpness
of the curve.
8. Keyword :always-less was added to gather-until. Normally, gather-until gathers values in a list
until the sum is >= a specified total. If :always-less is true, the sum will be <= the total.
9. Expressions bound to the keywords :low and :high can now vary over time in map-text.
10. Optional parameter loop was added to jump. The chosen chunk of values can be looped some
number of times before the next jump is made.
11. Keyword :between was added to get-intervals. Normally get-intervals returns the intervals
from the first value to each other value in the stockpile. If :between is true, the intervals between
each value in the stockpile are returned.
12. Keyword :first was added to all of the chaotic generators. If true, they will return the initial
state as the first result.
13. Various other corrections and adjustments were made to on-the-fly, otf, cal, from-number,
join, series-value, convert, convert/time, 2-masks, and notename.
New shortcuts for generators
14. Arc is a shortcut for exponential-motion. This means arc could be used anywhere where
exponential-motion could be used.
15. Gl is a shortcut for generate-line.
16. Ev is a shortcut for exponential-value.
Additions or adjustments to the interface
17. In the dialogs for Index and Annotated Index, the arguments of the current function are
displayed at the bottom of the dialog.
18. In the Csound and OSC File options, it is possible to select the application to play the sound

14

file instead of relying on the system default value.
19. A menu item Play Selection/Loop and a corresponding dialog were added to allow part of a
section to be played and/or looped.
20. Various minor adjustments were made to the design of dialogs including the borders and
default buttons.
21. Various corrections and adjustments were made to plotting routines, including the plotting of
multi-controller objects, midi performance objects, and xy value pairs.
22. The issue of the disappearing cursor in edit windows was addressed.
23. A problem with cut/copy/paste when navigating a dialog with the cursor was corrected.
24. The kill menu item was made more effective.
25. Fixed a bug in displaying the Object dialog that caused the startup process to hang.
26. The processes behind the menu items for recent environments and recent examples were
improved.
27. Discrepancies in the printing of floating-point pitch names were addressed.
28. Searching for argument names in a binary OSC file with multiple synthdefs produces more
reasonable results.
29. A keyboard shortcut was added for saving lisp text files.

Release notes AC Toolbox 4.4.3
1. Several changes were made in regard to using cumulative spectrum data via the tool readspectrum-file. In addition to importing data produced by Audacity and Amadeus, it is now also
possible to read data produced with SPEAR and the Csound utility Hetro. In that case, readspectrum-file will return one pitch and amplitude value per track. A cumulative or static spectrum
is one set of values and is useful for producing chords or pitch sequences. This is not to be
confused with the use of read-tracks-file which already could read data from SPEAR and Hetro and
produce a continually changing output.
2. Read-spectrum-file now includes keywords to round the spectral data (e.g. to semitones,
quartertones, etc.), to adjust the frequency value used for converting to notes (instead of using
440 Hz for a4), and the ability to filter the returned peaks to only include unique values (which
may not have been the case after the data was rounded).
3. The spectral data read from SPEAR or Hetro can use all of the available spectrum tools, such as
spectrum->pitch, spectrum->window, spectrum->structure, etc. and the generator spectrum>chord. The syntax of these tools was slightly adjusted since keyword round now occurs when the
spectrum is read rather than each time a tool is used. The tools will reflect the choices made in
read-spectrum-file.
4. Tool peaks? was added to return the number of peaks in data read from read-spectrum-file
should that information be forgotten or unavailable.
5. Several changes were made to the treatment of spectral data which is read with read-tracksfile. A keyword average was added. This will average track data within a specified time span, such
as 1000 ms. The result could be considered as a kind of chordal reduction of the spectral changes.
A keyword filter will filter repetitions in each track. The keywords for rounding pitch data and
changing the frequency base were moved to read-tracks-file and are no longer needed in maptracks.
6. Data read with read-tracks-file can now be plotted.
7. A problem with map-tracks not producing accurate results at time 0 has been fixed. In addition,
map-tracks enforces a minimum note duration of 1 ms.
8. When map-tracks is used to make a structured section, the clock unit is no longer ignored. The
data returned by map-tracks is in ms. Any clock unit above 1 will slow down the data.
9. Tool pitch-track has been added. It will return a list only containing pitches from one or more
tracks of data read with read-tracks-file.
10. Tutorial 20 about using spectral analysis data in the AC Toolbox was rewritten to reflect the
above changes. The documentation for read-spectrum-file, read-tracks-file, etc. was updated.
Previous users of the spectral analysis instructions may want to check this documentation for a
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discussion of the current syntax.
11. Some new generators were added:
a. linear-value and linear-choice use a random distribution which favors lower or higher
values depending on the value of the keyword direction.
b. triangle-value and triangle-choice use a random distribution with a triangular density
curve (the peak is in the middle).
c. morph produces a straightforward interpolation between two values depending on an
index value. This is simpler approach than what is used in the mutate generator.
d. line is a shortcut for the generator line-segment.
12. Tool pick-editor-font was added. It does what its name suggests. One use for this would be in
making presentations where a large font size is needed. Editor refers to the Lisp editor, not the
various dialogs in the AC Toolbox.
13. Some adjustments to generators or tools were made.
a. If take receives a negative number for one of the number parameters, the next value
form will be used indefinitely.
b. Keyword step was added to loop-through. It allows skipping values when looping through
a list or stockpile.
c. An optional parameter was added to jump to allow it to pick a new step size each time
instead of only once per jump.
d. The number parameter in produce can be a generator, stockpile, etc.
14. Some bugs were fixed including some in series-value, jump, combine, for-example; in dealing
with Lisp editor fonts; and in the menu items for recent environments and examples.
15. The stopping of data flow to a Capybara has been changed to be less abrupt.
16. The source code was recompiled with a new compiler which solved several problems and
probably has created many new ones.

Release notes AC Toolbox 4.4.2
1. A preference (Midi Scheduler Overdrive) was added. When off, it significantly reduces the cpu
use of the Midi scheduler. Older, slower computers may not function as well when it is off,
therefore the default value for this preference is on.
2. Generator grow was added. It can produce geometric and arithmetric series. By using timevarying input, the series itself can change over time.
3. The behavior of the round keyword in many generators and tools, in particular those related to
spectral composition, was adjusted. In addition to rounding the values to integers or not, a value
such as 0.5 can be bound to the keyword. This will round to quarter-tones. Other values are also
possible. This change concerns spectrum->pitch, spectrum->chord, spectrum->structure, hz>midi, harmonic-chord, frequency-shift-chord, and ring-modulate-chord.
4. A facility was added to edit the contents of a stockpile. In the Objects dialog, when the popup
menu for stockpiles has been selected, the Edit button will copy the values in the selected
stockpile and enter them in a specify stockpile dialog. Values can be then be changed, deleted,
etc. before making the stockpile (again).
5. Tool sum was added. It sums numbers in a stockpile or produced by a generator.
6. Tool extract was expanded to allow extracting a list of attack times in milliseconds (raw-attack).
7. Generator without was extended to allow the use with lists and stockpiles in addition to
generators.
8. Tool predicate was adjusted to allow the function quote (#') to be omitted although it still can
be used.
9. Tool get-object-duration was added to return the durations of sections and communities.
10. Tool get-length will now also return the number of events in a density section.
11. Bugs were fixed in act-if and in the Objects dialog for stockpiles. A bug concerning the use of 2
monitors where the menu bar is in the one on the right was corrected.
12. Issues regarding the labels for 2d plots as well the title for plot and histogram windows were
addressed.
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Release notes AC Toolbox 4.4.1
1. This release contains some minor adjustments to facilitate use with Mac OS 10.5 (Leopard).
2. Tool pitch-interval-filter was added. It can be used to filter sections to remove notes reflecting
certain pitch intervals. The filtering can also be limited to simultaneous events. The tool is a
generalization of pitch-repetition-filter.
3. Generator metric fractions was added. It produces groups of values that equal 1 to simplify
some kinds of rhythmic organization.
4. Tool duplicates was expanded to allow the diversity value to vary over time.
5. The formatting of the html output of tool help->file was improved.
6. The editing possibilities for Csound .csd and .orc files were expanded.

Release notes AC Toolbox 4.4
1. This is an Universal binary and works on MacOS 10.3.9 or higher with Intel or PPC processors.
Additions and clarifications
2. The tutorial included with the application (Using the AC Toolbox) was updated to reflect the
current Universal Binary version of the program.
3. The different versions from the beta release (standard and programming) have been replaced
with only one version of the AC Toolbox which includes a complete Common Lisp interpreter.
4. Menu item Make (Default Button) was added. This allows objects to be made with a keyboard
shortcut. Other dialogs with a default button, such as Test Value, can be perform the operation
associated with that default button with this shortcut.
5. Keyboard shortcuts were added to the menu items Evaluate Selection and Evaluate All.
6. Menu items Find and Find Next were added.
7. An option was included for histograms to round off the values to some arbitrary unit before
making the histogram.
8. The situation concerning Emacs key bindings has been clarified. Key bindings which are known
to refer to non-available commands have been removed. A button was added to the Lisp Editor
window to produce a list of available Emacs bindings. The help text for the Lisp Editor window was
also updated.
9. Documentation was added for the programming tools act-choose-file-dialog and act-choosedirectory-dialog.
Bug fixes
Some of the bug fixes fall into the following five categories:
Specification
10. Specifying various objects (as opposed to making them) did not always work as expected.
Forgetfulness
11. Midi source and destination did not always get reset properly on startup.
12. The options for the Other histogram dialog did not get remembered.
13. Editing commands such as cut/copy/paste were forgotten if Options had been selected.
14. Midi Controllers did not always get reset at the end of playback.
15. The Toolbox forgot how to plot shapes and masks if they had been loaded from an Examples
file.
Housecleaning
16. The cursor is now reset as part of the Kill sequence.
17. The interruption of Capybara playback is handled more smoothly.
18. The General Midi setup is cleared during Kill.
Dialog Errors
19. Minor errors in the dialogs for Csound Analysis, Multi Controller, and the help button (?) were
fixed.
Actions
20. Interpolate now prints its finish value (if requested with a keyword) in the Text Output window.
21. Show applies a generator properly if it is used with the number-per-line keyword.
22. Various issues with respect to closing previous windows (if that option is selected) were
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resolved.

Release notes AC Toolbox 4.4 b1
1. This is an Universal binary and works on MacOS 10.4 or higher with Intel or PPC processors.
2. This is a beta version. Comments are welcome: paul@koncon.nl.
3. Two versions exist of this release: 4.4b1 and 4.4b1-prog. The latter version contains a more
complete Common Lisp interpreter and is primarily intended for users wishing to add a lot of
their own Lisp code to use with the AC Toolbox.
4. A different Lisp development environment was used for this version. All of the GUI code, the
scheduler, and various bits of other things were rewritten for this Lisp environment (LispWorks
instead of MCL). This could lead to a lot of new issues and bugs. Reports welcome at the above
address.
5. A few tools have been renamed (to prevent conflicts with LispWorks):
plot (formerly display)
element (formerly current)
load-sound-file (formerly read-sound-file)
6. The default value for middle C (Midi note number 60) is c4 instead of c3. This can be changed
in the Preferences.
7. Preferences
The Preferences dialog allows some new choices:
The window style (which by default is brushed metal) can be reset to
the standard, Aqua style for new windows.
The amount of window transparency can be set for new windows.
The behavior for the expressions used in help windows (plot,
histogram, and for-example) can be set to always close the
previous result window or not.
The size of most fonts and dialogs can be adjusted to one of three settings:
normal, small, big
Small reduces the size for those cramped for screen space.
Big increases the size and is suitable for using with a projector.
There is a slight change in the format for saving objects in files. The
current version can read files in the old format. However, for a
previous version of the AC Toolbox to read files for the current
version, the environment should be saved in the Old Format.
8. Compatibility
Files produced by the AC Toolbox, using either an Intel or a PPC processor,
are interchangeable.
Environment files produced by earlier versions of the AC Toolbox, can be
read in the current version.
Objects saved in the New Format (see Preferences) cannot be read in older
versions. To read environment files produced by the current version
in older versions of the AC Toolbox, save the objects in the Old Format.
Csound hetrodyne analysis files should be made on the same type of
processor as the one used by the AC Toolbox. This means, hetro
files made on an Intel processor can be read by the AC Toolbox
running on an Intel processor.
9. GUI issues:
Input panes do not balance parentheses in Lisp expressions. Most panes
do have a check box which opens an editor pane which does balance
parenthesis and allows more extended editing. Even many Emacs
commands can be used in the edit pane.
To move the cursor to a new line in an input pane, use the menu item
Edit>Insert Newline (CMD-RETURN).
The Play dialog was removed. To play an object, select it in the Objects dialog
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(Tools > Show Objects). The menu item Tools>Play will play or stop
playing the item selected in the Objects dialog.
A Remake button was added to the Objects dialog. This is to remake the
selected object (i.e. use the input specification to produce new output).
The Input button in the Objects dialog will search for an open, unchanged
dialog for the object before it opens a new one.
The category Verbs was added to the Annotated Index.
Parallel sections can have an offset time number between the sections.
Help windows have been split into two panes: one contains text and the
other contains examples which can be evaluated to values
produced with the generator, tool, or transformer. To evaluate the
examples, put the cursor at the end of the expression and select
ENTER (not RETURN). Alternately, COMMAND-ENTER could
be used. Or the example expression could be selected and the
menu item Edit>Evaluate Selection could be used.
The menu item File>Text>Open opens a Lisp edit window. Lisp expressions
can be entered and evaluated in the same way as described above
for examples. The result of the evaluations will be appear in the
echo area at the bottom of the editor. Various Emacs expressions are
available for editing. CTRL-S allows incremental search. The symbol to
search is entered in the echo area. The echo area can be cleared
with ESC.
The check box to the right of many input panes opens an editor.
The symbol ! in some windows indicates that the line wraps around to the
next one. Increasing the size of the window may remove this indicator.
Options buttons have been added to various dialogs to control their behavior.
In particular, they control whether previous windows of the same type
as the ones produced, should be closed. This means, that choosing
help for a generator in the Index dialog, could cause the previous help
window to close. Plotting with the Plot dialog could cause the previous
plot window to close, etc.
A Listener can be opened via Other>Listener.
10. A few tools and generators were added:
print-result
prints a single result in a help window
clear-preference-file
erases the current preference file and will restart
(eventually) without any preferences
lehmer-value
generates deterministic patterns
lehmer-choice
bv
a shortcut for beta-value
11. A few changes were made to existing generators and tools:
read-spectrum-file requires a keyword to read Amadeus files. The default
value is for Audacity.
notename
a bug concerning octave numbers was fixed
ring-modulate-chord
added keyword :block0 to remove 0s from result
12. Miscellaneous
If CSound is to be used, Csound 5 should be installed in /usr/local/bin. This
is the location used by the installer from SourceForge.
The tutorial included with this release is the old one. The pictures of
dialogs, etc. do not match the current program. The changes described
in the release notes are also not reflected in the tutorial. Nonetheless,
it should help a new user to understand the basic workings of the AC
Toolbox.
A few examples in the tutorial examples folder have been adjusted to work
with this version of the AC Toolbox.
The stream control object is not implemented.
The File>Last File Name? menu item has been renamed
File>Current Environment File.
Help->window has been replaced with help->file.
Various anti-clutter keyboard shortcuts involving CTRL-CLICK have been
replaced with options, either in the Preferences dialog or in the Options
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for various dialogs.
13. Issues
Occasionally, errors messages may not be caught by the AC Toolbox and will
be printed in a window of the Terminal application. Ignore the contents
of the Terminal window, close it, and continue in the AC Toolbox.
On rare occasions, the printing in the Terminal window may be followed by
a message from the system that the AC Toolbox crashed. Close the
Terminal Window, click on Reopen in the crash message, and you
can continue working where you left off in the AC Toolbox.

